Title

Message

Confirm

<< DiscussionsReply

Windows 10 resetting notepad

Avatar from Gravatar.com
Joel38
2 discussion posts
Hi,

Within the past week I've noticed that rebooting Windows 10 seems to be resetting the default back to notepad. I can run NotepadReplacer again to fix it for my session, but I'm certain now that each reboot will cause it to revert back to using notepad.exe. My assumption is that some recent Windows Update is the culprit.

Have you seen this behavior and is there any sort of fix/hack/resolution to it?

NotepadReplacer 1.1.6
Windows 10 Pro Version 1607

Thanks in advance!
-Joel
Apr 21, 2017  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
I've re-tested Notepad Replacer on Windows 10 1607 here with a few reboots and didn't run into any issues. Do any other settings on your system get reset? Is this a personal computer, or a company computer that might have some central IT policies being applied to it?
Apr 24, 2017  • #2
Avatar from Gravatar.com
Joel38
2 discussion posts
I just tested after another reboot and it was not reset. I'm not sure what the culprit was over the last 3 or 4 reboots, but it seems to have stopped doing it. Thank you for looking into it.
Apr 24, 2017  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, glad to hear it's all good now!
Apr 25, 2017  • #4
Avatar from Gravatar.com
Arete
2 discussion posts
Just made an account to report this. I work in IT and I have recently installed multiple computers with Windows 10-1709 and I have had the same problem on all of them.

Notepadreplacer used to work but for some reason it has stopped suddenly opening files in Notepad instead of my Sublime Text 3.

Wild guess; it seems that Windows might be protecting changes to the registry or something. Such a shame because I simply love this app.
Nov 16, 2017  • #5
Avatar from Gravatar.com
Arete
2 discussion posts
Might have solved it bytaking ownership of:

Code


Described in this guide: https://www.howtogeek.com/262464/how-to-gain-full-permissions-to-edit-protected-registry-keys/

Then I added this to the registry:

Code

Nov 16, 2017 (modified Nov 16, 2017)  • #6
Was this helpful?    
<< DiscussionsReply