Processing Ajax...

Close Dialog


Close Dialog

Close Dialog

Close Dialog

User Image
1 discussion post

I'm using NotepadReplacer 1.1.4 on Windows Vista Ultimate 64-bit and, for the most part, it works beautifully. However, if I create an Explorer shortcut to notepad.exe, it opens the standard Windows Notepad rather than the target editor configured by NotepadReplacer (SublimeText, in my case, but the specific editor doesn't matter).

The cause of this problem is that 64-bit Windows has two different Image File Execution Options registry keys; one for 64-bit applications and a second one for 32-bit applications:
1) HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options
2) HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Image File Execution Options

The NotepadReplacer installer creates a "notepad.exe" subkey under the second of these (below the Wow6432Node key) but not under the first, which is the one used by Windows Explorer under 64-bit Windows. If I manually create the appropriate notepad.exe key and Debugger value in the first location, then Explorer shortcuts to notepad.exe redirect to the configured editor, as expected:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\notepad.exe]
"Debugger"="C:\\Program Files (x86)\\Notepad Replacer\\NotepadReplacer.exe"

Thanks for the great utility.

Apr 22, 2011  • #1
Keith Lammers (BFS)'s profile on
Definitely sounds like an issue we should be able to fix pretty easily but I'd like to be able to reproduce it so that we know it's fixed. Could you please outline the steps you took to create the Explorer shortcut to notepad.exe?

Apr 22, 2011  • #2
Jon Tackabury (BFS)'s profile on
Notepad Replacer 1.1.5 is now available and should fix this issue for you:

May 5, 2011  • #3
Subscribe to this discussion topic using RSS
Was this helpful?  Login to Vote(-)  Login to Vote(-)